Skip to content
This repository was archived by the owner on Feb 24, 2025. It is now read-only.
This repository was archived by the owner on Feb 24, 2025. It is now read-only.

A few services fail to start up because upstream does not have systemd-tmpfiles configurations for them #24

Description

@tulilirockz

I believe most of these errors arent anything to worry about, but it would be interesting to evaluate if these are serious issues or not, I believe some of them are being caused by weird selinux policies.

  • audit and audit-rules fail because they dont create /var/log/audit and dont have permission to create /var/log/audit/*.log (apparently it fails because /usr/lib/tmpfiles.d/var.conf has a duplicate /var/log entry)
  • auditd also seems to not be able to start up because of selinux issues ("avc denied" the creation of those folders and setattr too)
  • rpc.statd fails because /var/lib/nfs/statd does not exist
  • rpcbind fails to open /run/rpcbind/{rpcbind.xdr,portmap.xdr}
  • there is some tmpfiles misconfiguration that tries to create /usr/local/man and fails because it is read only (and it tires to also create /home and /srv and fails too)
  • atd tries to modify a file called /var/spool/atd and fails because it doenst exist
  • setroubleshoot tries to create and chown and chcon /var/lib/setroubleshoot/setroubleshoot_database.xml and fails because it doesnt exist
  • /usr/sbin/alsactl: save_state:1652: Cannot open /var/lib/alsa/asound.state for writing: No such file or directory

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions